Can Anyone Help Me Figure Out This Last Bug?

This entry is part 8 of 12 in the series Version 2 WordPress Plugin

Okay, the Version 2 WordPress plugin looks very good, but I have one last, nasty bug, and it is proving extremely difficult to track down. I could use the help of some more eyeballs on this one.

First, I’m pretty sure the bug is actually in Google Maps, but they aren’t gonna fix it, as the V2 API has already been deprecated. It also doesn’t happen in the old plugin, which uses almost exactly the same code. So I need to work around the bug.

NOTE: This only manifests itself in WebKit-based browsers, like Chrome, Safari and iCab.

In the two images below, you can see the problem:

The new plugin The old plugin
The New Plugin. Note the Shadow of the Window. The Old Plugin. No Shadow Problem.

Any ideas? I’m almost positive that it is a CSS problem.

This entry was posted in BMLT Development. Bookmark the permalink.

4 Responses to Can Anyone Help Me Figure Out This Last Bug?

  1. Chris M. says:

    Okay, I’ve figured out which CSS rule causes the problem. It’s this one:

    table#bmlt_container *
    {
    margin:auto;
    }

    the problem is that I can’t easily just yank it. It’s needed to prevent the theme from screwing up the plugin. I just have to apply it more judiciously, which will take a bit.

  2. Chris M. says:

    Nope. That was a different problem, and I got it fixed easily.

    Now I am still back to the same issue.

    However, I now have a test setup with two identical blogs set up on my laptop; one with the new, and one with the old. It will take a while, but I’ll figure it out.

  3. Chris M. says:

    I am now getting the bug to happen in the original plugin as well. I think it may be a fairly new bug in the Google Maps 2 API.

    In any case, it does not seem to be a problem caused by the plugin. It’s possible that the theme and/or other plugins may be influencing it.

  4. Jonas J says:

    Something similar happens in MSIE9 🙁

Leave a Reply